Talk Advanced Scipy

Abstract

Prerequisites:

Proficiency with NumPy and matplotlib

Software requirements:

IPython, NumPy, SciPy, Cython (optional) [1], matplotlib

Make sure that you can execute the following commands before the tutorial:

import numpy
print numpy.__version__

import scipy
print scipy.__version__

import matplotlib.pyplot as plt
plt.plot([1, 2, 3])
plt.show()

Content:

We give a brief overview of the scipy package in terms of infra-structure, packaging, its relation to scikits, build requirements, etc. After examining the structure of the numpy array, we interactively explore certain scipy components, such as spatial, sparse and ndimage in more detail. We conclude with a brief discussion of the other tools in the SciPy ecosystem and a Q&A.

Material: http://mentat.za.net/euroscipy2011/adv_scipy_notes.tar.gz

[1]http://www.pythonxy.com or http://www.enthought.com/products/epd.php for one-click installers
tagged by
no related entity